How To: '99-'04 GMT800 OEM E-fan upgrade

5.3silverado

Full Access Member
Joined
Apr 9, 2012
Posts
137
Reaction score
0
Well got electric fan setup today and they cut wires right at plug ins. Now trying to find plugs with some wire on them so I can make a harness.

Sent from my XT901 using Tapatalk 2
 

5.3silverado

Full Access Member
Joined
Apr 9, 2012
Posts
137
Reaction score
0
Got a fan relay block with harness on order today. Now time for alternator and radiator.

Sent from my XT901 using Tapatalk 2
 

5.3silverado

Full Access Member
Joined
Apr 9, 2012
Posts
137
Reaction score
0
E-fan Upgrade

Now will the 145 amp alternator from 05-06 just plug in place of my stock 105 amp alternator on my 2004 silverado?
 

ScottyBoy

No, that's not a banana in my pants.
Joined
Jun 5, 2009
Posts
13,668
Reaction score
3
Location
Shreveport
Now will the 145 amp alternator from 05-06 just plug in place of my stock 105 amp alternator on my 2004 silverado?

05-06 have a different type of plug on the alternator. You need a 145a from a 03-04 Suburban. It willbolt right up and plug right in. You will need a longer belt though. When buying the belt, they should ask which alt you have. You will need a belt to go with the 145a alt.
 

5.3silverado

Full Access Member
Joined
Apr 9, 2012
Posts
137
Reaction score
0
Ok that's what I needed to know. Getting closer to having all the stuff I need.

Sent from my XT901 using Tapatalk 2
 

5.3silverado

Full Access Member
Joined
Apr 9, 2012
Posts
137
Reaction score
0
Anyone know what part number is for the pins that fit into pcm connector?

Sent from my XT901 using Tapatalk 2
 

5.3silverado

Full Access Member
Joined
Apr 9, 2012
Posts
137
Reaction score
0
How do I tell if high speed works on my electric fans?

Sent from my XT901 using Tapatalk 4 Beta
 

ScottyBoy

No, that's not a banana in my pants.
Joined
Jun 5, 2009
Posts
13,668
Reaction score
3
Location
Shreveport
How do I tell if high speed works on my electric fans?

Sent from my XT901 using Tapatalk 4 Beta

When both fans are on at the same time, and the AC is on, that should be high speed. If the coolant isn't up to temp yet but the AC is on, one fan should be on at high speed and the other fan should be off. If the coolant gets up to the proper temp and the AC is off, both fans should be on at low speed.
 

5.3silverado

Full Access Member
Joined
Apr 9, 2012
Posts
137
Reaction score
0
Ok just wanted to make sure the fans are working properly.

Sent from my XT901 using Tapatalk 2
 

leach

I'm NEW... What now?
Joined
Mar 24, 2016
Posts
1
Reaction score
0
Thanks for the help

I know this thread is old. But I was attempting to do this todayusing the instructions from a website that sells the harness.I was having a hard time finding the mysterious green wire for the AC clutch relay. I found this Write upand it made my life a lot simpler. thanks guys
 

Members online

Forum statistics

Threads
28,735
Posts
1,103,127
Members
4,709
Latest member
BeaGeiger9
Back
Top