Need Help, Steering Wheel Buttons, 2007 Silverado

OneSlowRhino

I'm NEW... What now?
Joined
Apr 8, 2017
Posts
13
Reaction score
0
I'm new here, I hope I posted in the right place,

I have a 2007 NNBS with the 4.8, to give a little backstory which might help diagnose my issue, this truck is hooked up with a VIPER remote start and Car alarm, which both seam to work correctly, also has an aftermarket Stereo.

The issue I'm running into is none of my steering whee buttons work, on either side and don't even light up. My main concern is cruise, I drive a lot and need this, nothing worked when I bought it so I'd like to assume its and easy fix or related to the auto start/stereo, I'm really not wanting to take this to GM for a fix, after days of digging, it could possibly be the Clock Spring? Claims a very expensive part, and not really find anything about how to test or change it.

Any and all help would be helpful. Thanks!
 

Attachments

  • Snapseed.jpg
    Snapseed.jpg
    188 KB · Views: 8

66nova

Doctor Bob - Fastest Doctor Around
Lifetime Supporting Member
Joined
May 21, 2009
Posts
7,534
Reaction score
54
Location
Fort Worth, TX
Have you checked all the fuses?

Did you have the Remote start and stereo installed or was it installed?

Did someone upgrade the steering wheel? Is it plugged in properly?
 

66nova

Doctor Bob - Fastest Doctor Around
Lifetime Supporting Member
Joined
May 21, 2009
Posts
7,534
Reaction score
54
Location
Fort Worth, TX
I would start with pulling the airbag and seeing if everything is hooked up.
 

drperry

Fox 1! Fox 2! Fox 3!
Lifetime Supporting Member
Joined
Sep 17, 2009
Posts
13,099
Reaction score
101
Location
Grande Prairie, Alberta, Canada
Cruise control should be completely unrelated to your stereo not responding to the wheel controls... Check your cruise fuse... Then wiring.
 

OneSlowRhino

I'm NEW... What now?
Joined
Apr 8, 2017
Posts
13
Reaction score
0
I'd say it's all related, mainly because nothing works on the steering wheel. The horn works and that's it, nothing lights up or works, and as for fuses, I've looked in the book and online, I may not understand Chevy lingo, but I can't seem to find which fuse it would be fore the steering wheel controls.

I bought the truck as it is, remote start and after market stereo was all hooked up when I bought it.
 

66nova

Doctor Bob - Fastest Doctor Around
Lifetime Supporting Member
Joined
May 21, 2009
Posts
7,534
Reaction score
54
Location
Fort Worth, TX
If nothing works and no lights on the steering wheel my first concern would be the plug behind the airbag at the top on the steering wheel. It supplies all the power to and from buttons.

Doesn't take much to remove airbag, I would check it out.
 

OneSlowRhino

I'm NEW... What now?
Joined
Apr 8, 2017
Posts
13
Reaction score
0
Well I'm back to stage one, I just pulled the airbag off, and everything looks plugged in and no loss wires or plug ins. And I looking at the clock spring?
 

OneSlowRhino

I'm NEW... What now?
Joined
Apr 8, 2017
Posts
13
Reaction score
0
Well I'm back to stage one, I just pulled the airbag off, and everything looks plugged in and no loss wires or plug ins. And I looking at the clock spring?

Also checked all related fuses and those looks good.

Not sure if any of this has to do with it but my pedal adjustments, TC, and other button don't work either.
 

PenguinLTZ

Not a Mod
Lifetime Supporting Member
Joined
May 21, 2009
Posts
25,028
Reaction score
242
Location
Inland NW
Well I'm back to stage one, I just pulled the airbag off, and everything looks plugged in and no loss wires or plug ins. And I looking at the clock spring?

Also checked all related fuses and those looks good.

Not sure if any of this has to do with it but my pedal adjustments, TC, and other button don't work either.

You need to take it to the dealer and have the BCM programming flashed, if all that is going on, too.
 

OneSlowRhino

I'm NEW... What now?
Joined
Apr 8, 2017
Posts
13
Reaction score
0
Damn, that's why I was afraid of.

I'm wondering if it has to do with this Viper alarm and shit. Might take it to the local Car Electronics place and see if they can't diagnose anything before I take t to the dealer.
 

Staff online

Members online

Forum statistics

Threads
28,735
Posts
1,103,127
Members
4,709
Latest member
BeaGeiger9
Back
Top