My 2002 Bravada rear hatch is broken

Z71 Kris

Independence...
Joined
May 21, 2009
Posts
8,984
Reaction score
0
Location
N. East Ohio
What up genitals! I have been busy as all get out for the past however long, but I am having an issue with a new to me 2002 Bravada. I know I most likely have a broken wire in the boot between body and rear hatch, but the real problem lies in the fact that the previous owner had attempted to fix the problem and destroyed the lock inside the panel, and I cant get the the lock to disengage. When i opened the panel every thing was apart. There is no spring, and I have no idea where to start with this, I was able to get the rear glass open with the little hole, and then was able to pry the back panel open enough to see a little bit down there and spent about 4 or 5 hours fiddling with it this afternoon. I've tried googleing but every thing I find just says move this lever and move that lever and open it, but that won't work here. Any help would be appreciated.:dan::brain::wookie:
 

Draenor

KILL ALL HUMANS!!!!
Joined
Jun 2, 2009
Posts
5,896
Reaction score
0
Location
Now in Scott,LA
It's a PITA. I could show better if not at work and back at the house. I hate the blazer and trailblazer platform.

Anyhoos...I'll try to describe this as best as I can.

In the bottom hole. You need to pry the latch that holds the door locked. Its the latch that goes a the U shape striker bolted to the body. You need to flip it up from the locked position. It will click. The next step is the latch release. If you look dead on thru the hole, you'll see the lever with a 1/2" size hole. Jimmy this to the right(or left,cant remember). This will enable you to use the outside handle to open the hatch.
 

Z71 Kris

Independence...
Joined
May 21, 2009
Posts
8,984
Reaction score
0
Location
N. East Ohio
The latch on the left that I flip up does not stay up, and the latch release just flicks back the left after I push it to the right. I've been spraying liquid wrench in there trying to loosen something up, but I can't get anything to stay where it goes. It was pretty corroded in there some I'm hoping that the liquid wrench will help this.

Sent from my SM-N910V
 

Z71 Kris

Independence...
Joined
May 21, 2009
Posts
8,984
Reaction score
0
Location
N. East Ohio
Nope not yet. I have messed with it here and there since but I can't figure it out. The guts could be frozen, or something could be broke.

Sent from my SM-N910V
 
Last edited:

Members online

Latest posts

Forum statistics

Threads
28,741
Posts
1,103,354
Members
4,712
Latest member
brisbaneweddingph
Back
Top