HOW-TO: Replacing Instrument cluster stepper motors in a '03-'07 GMT800

ScottyBoy

No, that's not a banana in my pants.
Joined
Jun 5, 2009
Posts
13,668
Reaction score
3
Location
Shreveport
The GM 2003-2007 GMT800 Trucks and 03-06 SUV's were plagued by defective stepper motors in the instrument cluster. GM's only solution for this is to replace the entire cluster at a cost upwards of $300 or more. Plus the cost of having your truck's mileage programmed into the new cluster, which can easily tack on another $100. Your other option is to send it off to a shop that specializes in speedometer repairs, yet that will still cost you about $200 or more. If you know how to solder, you can replace the stepper motors very easily on your own. You can find replacement stepper motors on Ebay or Amazon for around 30-40 bucks. Once you get your new stepper motors, heres how to swap them out. I just replaced the stepper motors in a 2004 Denali cluster and took lots of pics.

First, you need to remove the cluster from the truck. If you don't know how to do that, CLICK HERE for instructions.

Then you need to lay the cluster on your table or workbench to take it apart.
First, you need to remove the lense/cluster bezel by unclipping the tabs around the cluster to pop it off. There are several clips across the top and two on the bottom. Unclip the top ones first and the bottom ones will come off a LOT easier.
2012-07-08_12-30-13_731.jpg

2012-07-08_12-30-03_422.jpg


Here is the cluster with the bezel removed.
2012-07-08_12-50-59_822.jpg



Once the bezel is removed, you need to mark the setting for your needles. put a piece of tape to the left of each needle. Then rotate each needle as far to the left as it will go, and mark a line on your tape with a pen or marker.
IMG_20120708_125934.jpg


After each needle position is marked, you need to pop the needles off. This is most easily accomplished by using a dinner fork. Cover the fork with tape if you are worried about it scratching your gauge face overlay.
2012-07-08_12-55-54_692.jpg

2012-07-08_12-56-06_456.jpg


After all your needles are removed and safely set aside, you can lift off the gauge face/overlay. It is only fastened by some small tabs, just pop it off these tabs and lift it off and set it aside.
IMG_20120708_125823.jpg

IMG_20120708_125901.jpg


Don't forget to lift out the trip odometer button after you lift off the overlay.
2012-07-08_13-00-37_461.jpg
[/QUOTE]

Now you have to lift out the clear light diffuser that is laying inside the cluster. Just carefully lift it straight up, it isnt secured to anything.
DSC02540.jpg

2012-07-08_13-01-11_479.jpg


The little white motors are the stepper motors that you need to replace.
DSC02541.jpg


You need to remove the board completely from the rest of the cluster housing to unsolder the stock stepper motors and solder the new ones in.
Just unclip the back cover to seperate it.
DSC02542.jpg


The white motors are the original motors and the new motors are black and slightly thinner. Here are a few shots comparing the two. The
2012-07-08_14-47-21_751.jpg

2012-07-08_14-47-42_328.jpg

2012-07-08_14-47-33_622.jpg


The motors have 4 solder pins, and 2 plastic locator pins, so they can only go in one way. The factory motors have the pins bent and soldered. You can either melt the solder and bend them back up to remove each motor, or snip them off as close to the board as possible, then melt the remaining solder to get the motor off. Desoldering wick can come in handy during the desoldering part.
2012-07-08_14-46-32_704.jpg


Now get the new stepper motor seated in place. Press it firmly against the board as far as it will go. The plastic pins might hold it in place during soldering, but you can also bend the pins down to help hold it too.
2012-07-08_14-49-58_976.jpg

Now just solder these 4 pins and you are good to go, now move on to the next stepper motor.
2012-07-08_15-16-08_914.jpg


One down, 6 more to go. :lol:
2012-07-08_14-50-59_499.jpg


Just repeat the desoldering and soldering process until you have all the stepper motors replaced.
2012-07-08_15-10-22_61.jpg


I also replaced all the light bulbs in the cluster with white LEDs.
2012-07-10_12-36-24_946.jpg

For more information on how to install the LEDs, click HERE.

Now just re-assemble the cluster in reverse order of disassembly. Pop the needles back on and line them up with the marks you made earlier on the tape. The needles need to rest on your mark when its moved as far left as the motor will turn. And just to be safe, go plug your cluster in your truck to test it before you remove the tape and pop the front bezel back on. If all is working fine, remove the tape and clip the bezel back on and admire your work.
IMG_20120710_155200.jpg


:cheers:
 
Last edited:

Kennyray

Full Access Member
Joined
Mar 9, 2010
Posts
39,251
Reaction score
335
Location
Ossian, IN
Re: HOW-TO: Replacing Instrument cluster stepper motors in a 03-07 GMT800

Great write up Scotty :thumbs:
 

BlueCollarPilot

Boy I say boy
Lifetime Supporting Member
Joined
Jan 15, 2012
Posts
2,428
Reaction score
0
Location
Louisiana
Re: HOW-TO: Replacing Instrument cluster stepper motors in a 03-07 GMT800

Very cool Scotty!
 

PenguinLTZ

Not a Mod
Lifetime Supporting Member
Joined
May 21, 2009
Posts
25,028
Reaction score
242
Location
Inland NW
Re: HOW-TO: Replacing Instrument cluster stepper motors in a 03-07 GMT800

Great write-up :thumbs:
 

NMRam

Still Here Because I'm Not There
Joined
Sep 25, 2009
Posts
8,477
Reaction score
45
Location
Ft Sumner, NM
Re: HOW-TO: Replacing Instrument cluster stepper motors in a 03-07 GMT800

Very nice write up Scotty!! :thumbs:
 

Texas Jim

Texas..It's a Whole 'nuther Country
Joined
Jun 18, 2009
Posts
49,927
Reaction score
0
Location
Ft. Worth
Re: HOW-TO: Replacing Instrument cluster stepper motors in a 03-07 GMT800

Very good write up...
Thanks... :cheers:
 

Wyley87

The '96 and I have a LOVE/HATE Relationship
Joined
Mar 10, 2010
Posts
1,099
Reaction score
1
Location
Granbury, Tx
Nice write up thanks for posting.

Is there a way to reset the needle if some one pulled it off once without marking it?


Sent from my iPhone 4s
 

Members online

No members online now.

Forum statistics

Threads
28,735
Posts
1,103,127
Members
4,710
Latest member
ready67
Back
Top