1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Head Unit Help!

Discussion in 'Car Audio/ Video/ Navigation' started by Boilerup15, Jul 13, 2013.

  1. Boilerup15

    Boilerup15 Hate Milk! Got Beer?

    Age:
    33
    Posts:
    7,030
    Likes Received:
    0
    Joined:
    Jan 21, 2010
    Location:
    Markle, Indiana
    My sister wanted a aftermarket headunit for her car, I picked her up a cheap JVC because she doesn't have much money being a college student. I installed it in her car yesterday and now her instrument panel won't work. :dunno:

    Her car is a 2002 Chrysler Sebring

    I know I have everything wired color for color. I am at a loss of what this could be.

    I unplugged the radio, and everything works as normal.
     
  2. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    the cluster does not work, or the cluster illumination does not work?
    EDIT: is it a 2-door, 4-door, or convertible?
     
    Last edited: Jul 13, 2013
  3. Boilerup15

    Boilerup15 Hate Milk! Got Beer?

    Age:
    33
    Posts:
    7,030
    Likes Received:
    0
    Joined:
    Jan 21, 2010
    Location:
    Markle, Indiana
    The cluster does not work, idk about the illumination. It is a 4 door.
     
  4. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    did you wire it straight or did you use an install kit?
     
  5. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    PM sent
     
  6. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    one thing to help narrow it down would be to unplug one of the radio connectors and to see which connector is causing the issue. Both the radio and the cluster work throught the body control module(BCM). One of my thoughts is that it is the BCM communication that is causing the issue with feedback. I do not think the BCM is bad since you said you unplug the radio and it works fine.

    That being said which radio was in it before? Was it the base radio, or one of the premium radios?
     
  7. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    I can e-mail all the wiring diagrams for all the radio set-ups for the 02 Sebring 4-door body styles, or post them on here if you would like, but there are quite a few of them.
     
  8. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    here is the start of them
     

    Attached Files:

  9. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    more
     

    Attached Files:

  10. Hickspanic

    Hickspanic There once was a man from Nantucket

    Age:
    38
    Posts:
    5,441
    Likes Received:
    0
    Joined:
    May 21, 2009
    Location:
    D-ville
    and even more
     

    Attached Files:

Share This Page