FASS Titanium 95 install

geektoad

redneck geek
Joined
Dec 10, 2009
Posts
2,448
Reaction score
81
Location
New Hampshire
....is going no where.

plastic shield is off.
jack under it holding it
straps are off

I can't reach or see anything on the back side of the tank where i'm supposed to disconnect the filler tube, return line and the wires.

I assumed I could drop it down on the jack a little to get access and see wha the hell is going on, but when I lower it, the front end drops but the rear doesn't budge. I don't want to drop it very far cause I don't want to break anything. There's probably 6-7 gallons in the tank, so not a lot of weight, but enough to bend something I can't see.

The install instructions from FASS are a fucking joke. No detail about anything and some stuff is just flat wrong (which fuse to put the add-a-fuse into).

The problem I'm having is this install (2015-2016) is different than the previous LML install, so there's not much info out there from anyone other than FASS's instructions.

one other thing i'm starting to worry about is whether the gooseneck hitch has something back there pinned, though it all looked clear when I was installing it.

I assumed this was going to be a simple install, and I really wanted this installed to pull the new camper, but at this point I might button everything back up in the morning and go after this when we get home from our trip.

grrrr.
 
Last edited:

OldCracker29

I've been knocked down drug out and left for dead
Joined
May 26, 2009
Posts
76,683
Reaction score
693
Location
NE Ohio
:frustration: I don't have a clue, but I'll give the thread a bump. :dunno:
 

PenguinLTZ

Not a Mod
Lifetime Supporting Member
Joined
May 21, 2009
Posts
25,028
Reaction score
242
Location
Inland NW
....is going no where.

plastic shield is off.
jack under it holding it
straps are off

I can't reach or see anything on the back side of the tank where i'm supposed to disconnect the filler tube, return line and the wires.

I assumed I could drop it down on the jack a little to get access and see wha the hell is going on, but when I lower it, the front end drops but the rear doesn't budge. I don't want to drop it very far cause I don't want to break anything. There's probably 6-7 gallons in the tank, so not a lot of weight, but enough to bend something I can't see.

The install instructions from FASS are a fucking joke. No detail about anything and some stuff is just flat wrong (which fuse to put the add-a-fuse into).

The problem I'm having is this install (2015-2016) is different than the previous LML install, so there's not much info out there from anyone other than FASS's instructions.

one other thing i'm starting to worry about is whether the gooseneck hitch has something back there pinned, though it all looked clear when I was installing it.

I assumed this was going to be a simple install, and I really wanted this installed to pull the new camper, but at this point I might button everything back up in the morning and go after this when we get home from our trip.

grrrr.

Just pull the fill hose pocket at the door and drop that all with the tank
 

PenguinLTZ

Not a Mod
Lifetime Supporting Member
Joined
May 21, 2009
Posts
25,028
Reaction score
242
Location
Inland NW
Your instructions are from a prior model? I got a color printout from Thorobred with mine, for my truck. Didn’t you get your stuff from them? They are super helpful
 

geektoad

redneck geek
Joined
Dec 10, 2009
Posts
2,448
Reaction score
81
Location
New Hampshire
no the instructions i got are from my model but it seems like they're glossing over some shit. don't know if i'm missing a page or something, but the newest instructions on FASS's site are the 11-14 ones. I picked a bad day to try and start this, and I don't have much time before we pick up the camper and go, so i'm going to put this off til after this trip. I have enough other things to worry about trying to prep for a trip in a fifth wheel for the first time less than 24 hours after we pick it up! :)
 

Darkanion

The space intentionally left blank.
Joined
Jul 5, 2009
Posts
41,305
Reaction score
361
Location
North Texas
no the instructions i got are from my model but it seems like they're glossing over some shit. don't know if i'm missing a page or something, but the newest instructions on FASS's site are the 11-14 ones. I picked a bad day to try and start this, and I don't have much time before we pick up the camper and go, so i'm going to put this off til after this trip. I have enough other things to worry about trying to prep for a trip in a fifth wheel for the first time less than 24 hours after we pick it up! :)

:lame: Where's your sense of adventure!?! :jester: :lol:
 

geektoad

redneck geek
Joined
Dec 10, 2009
Posts
2,448
Reaction score
81
Location
New Hampshire
taking a brand new 5er on a 4500 mile trip less that 24 hours after delivery is pretty damn adventurous. I think the penguin will back me up on that one :)
 

drperry

Fox 1! Fox 2! Fox 3!
Lifetime Supporting Member
Joined
Sep 17, 2009
Posts
13,099
Reaction score
101
Location
Grande Prairie, Alberta, Canada
no the instructions i got are from my model but it seems like they're glossing over some shit. don't know if i'm missing a page or something, but the newest instructions on FASS's site are the 11-14 ones. I picked a bad day to try and start this, and I don't have much time before we pick up the camper and go, so i'm going to put this off til after this trip. I have enough other things to worry about trying to prep for a trip in a fifth wheel for the first time less than 24 hours after we pick it up! :)

The 11 - 14s don't drop the tank to install...

Once you get the right instructions, it'll go quick

Sent from my SM-G930W8 using Tapatalk
 

PenguinLTZ

Not a Mod
Lifetime Supporting Member
Joined
May 21, 2009
Posts
25,028
Reaction score
242
Location
Inland NW
taking a brand new 5er on a 4500 mile trip less that 24 hours after delivery is pretty damn adventurous. I think the penguin will back me up on that one :)


Meh, no problem

:jester:


Did you get it figured out? Like I was saying, I just dropped the fill hose, door pocket and all together.
 

geektoad

redneck geek
Joined
Dec 10, 2009
Posts
2,448
Reaction score
81
Location
New Hampshire
taking a brand new 5er on a 4500 mile trip less that 24 hours after delivery is pretty damn adventurous. I think the penguin will back me up on that one :)


Meh, no problem

:jester:


Did you get it figured out? Like I was saying, I just dropped the fill hose, door pocket and all together.

I put it back together out of an abundance of caution. If anything had gone wrong and broke, I didn't have time to get parts and fix properly. I'll do the install when I get back, so I'm not rushed/stressed about it.
 

Members online

No members online now.

Forum statistics

Threads
28,735
Posts
1,103,127
Members
4,710
Latest member
ready67
Back
Top